Page rendering errors have subsided. Customers who are already logged in should reload their browser or refresh the desktop application to access the updated version. Agents logging in for the first time will be promptly notified of a new client version and should update accordingly.
Posted Apr 25, 2025 - 09:05 EDT
Identified
Root cause has been identified and mitigation steps have been put in place. Customers should begin to see recovery.
Posted Apr 25, 2025 - 08:58 EDT
Update
Service teams are continuing to actively investigate this issue. Next update 09:00 AM Eastern or sooner if information becomes available.
Posted Apr 25, 2025 - 08:36 EDT
Update
Teams are continuing to investigate root cause for latency in the UI. Next update 08:30 AM Eastern
Posted Apr 25, 2025 - 08:02 EDT
Investigating
We are investigating an issue that is impacting customers ability to answer interactions due to latency in the UI.
Posted Apr 25, 2025 - 07:40 EDT
This incident affected: Platform (Americas (US East), Americas (US West), Americas (Canada), Asia Pacific (Sydney), Asia Pacific (Tokyo), EMEA (Dublin), EMEA (Frankfurt), EMEA (London)).