Genesys Cloud System Status

Normal Operations
Degraded Operations
Partial Outage
Outage
Under Maintenance

Elevated Error Rates - EMEA (Zurich)

Incident Report for Genesys Cloud

Resolved

The platform provider has resolved this issue.
Posted Jul 08, 2025 - 12:15 EDT

Update

The platform provider continues to work toward resolution. Some services are seeing improvement but users may still experience issues with work items. Next update 12:45 Eastern or sooner as information becomes available.
Posted Jul 08, 2025 - 12:02 EDT

Identified

Some customers in the Zurich region may experience issues updating and creating work items. This is a continuation of the previous incident in which the platform provider is performing additional work to restore service to certain lambda functions. Next update 12:00 Eastern or sooner as information becomes available.
Posted Jul 08, 2025 - 11:13 EDT
This incident affected: Platform (EMEA (Zurich)).