Genesys Cloud System Status

Normal Operations
Degraded Operations
Partial Outage
Outage
Under Maintenance

Elevated Error Rates: Americas (US West)

Incident Report for Genesys Cloud

Resolved

Health checks are normal. Resolving incident. All clear time 1:45pm ET.
Posted Mar 27, 2025 - 13:55 EDT

Update

Mitigation steps are in progress; next update top of the hour.
Posted Mar 27, 2025 - 13:38 EDT

Identified

Elevated error rates have been identified in the Americas (US West) region. Customers may be experiencing issues with call notifications, answering calls, and completing calls. Teams are engaged for triage and mitigation. Next update 15 minutes.
Posted Mar 27, 2025 - 13:30 EDT
This incident affected: Platform (Americas (US West)).