Genesys Cloud System Status

Normal Operations
Degraded Operations
Partial Outage
Outage
Under Maintenance

Elevated Error Rates - Americas (US-West)

Incident Report for Genesys Cloud

Resolved

This incident has been resolved.
Posted Jul 30, 2025 - 19:05 EDT

Monitoring

Error rates have subsided and all health checks are passing successfully. Monitoring for stability before resolving.
Posted Jul 30, 2025 - 18:52 EDT

Identified

Teams are investigating an issue that is intermittently impacting users ability to make and receive WebRTC calls. Mitigation steps have been implemented and we are seeing improvement. Next update 19:00 Eastern.
Posted Jul 30, 2025 - 18:42 EDT
This incident affected: Platform (Americas (US West)).