Genesys Cloud System Status

Normal Operations
Degraded Operations
Partial Outage
Outage
Under Maintenance

Elevated Error Rates - EMEA (London)

Incident Report for Genesys Cloud

Resolved

This incident has been resolved.
Posted Mar 24, 2026 - 11:17 EDT

Monitoring

Mitigation steps have been implemented and we are monitoring for stability.
Posted Mar 24, 2026 - 11:14 EDT

Investigating

Teams are investigating an issue causing intermittent call failures in the London region.
Posted Mar 24, 2026 - 11:11 EDT
This incident affected: Platform (EMEA (London)).