Genesys Cloud System Status

Normal Operations
Degraded Operations
Partial Outage
Outage
Under Maintenance

Interaction Routing Issues - Americas (US-East)

Incident Report for Genesys Cloud

Resolved

We have successfully resolved the agent routing issues. The service teams have cleared agents stuck in incorrect statuses, stopped routing interactions to offline agents, and restored real-time queue visibility.
Posted May 08, 2026 - 13:30 EDT

Update

The fix is now being deployed to production. We anticipate 20-30 minutes to complete. Next update 13:30 or sooner as information becomes available.
Posted May 08, 2026 - 12:40 EDT

Update

Teams have developed a fix and are actively testing before deploying to production. Next update 13:00 or sooner as information becomes available.
Posted May 08, 2026 - 12:10 EDT

Identified

Root cause has been identified. The engineering teams are actively evaluating mitigation strategies and we have engaged additional technical resources to expedite resolution. As a work around, customers can remove the offline agents from queues. Next update 12:30 Eastern or sooner as information becomes available.
Posted May 08, 2026 - 11:34 EDT

Investigating

We are investigating an issue in the US-East region where interactions are being routed to unavailable agents. As teams work to restore, as a work around, customers can remove offline agents from the queue. Next update 11:30 Eastern
Posted May 08, 2026 - 10:51 EDT
This incident affected: Platform (Americas (US East)).