Genesys Cloud System Status

Normal Operations
Degraded Operations
Partial Outage
Outage
Under Maintenance

Analytics Delays - Americas (US-West)

Incident Report for Genesys Cloud

Resolved

This incident has been resolved.
Posted Jul 29, 2026 - 10:34 EDT

Monitoring

Mitigation steps have been implemented and the service is actively processing backlogged events. Once the backlog is clear, the service will be operating normally. Next update 11AM Eastern or sooner as information becomes available.
Posted Jul 29, 2026 - 10:17 EDT

Investigating

We are actively investigating an issue causing delays with all real time analytics data, including detail records, aggregate metrics, observation metrics and notifications.
Posted Jul 29, 2026 - 09:38 EDT
This incident affected: Platform (Americas (US West)).