Genesys Cloud System Status

Normal Operations
Degraded Operations
Partial Outage
Outage
Under Maintenance

Analytics Delays - Americas (US-West)

Incident Report for Genesys Cloud

Resolved

This incident has been resolved.
Posted Jun 24, 2025 - 13:35 EDT

Identified

Mitigation steps have been implemented and we are seeing improvement. Next update 14:00 or sooner as information becomes available.
Posted Jun 24, 2025 - 13:25 EDT

Investigating

Development teams are investigating an issue impacting Analytics Detail Records. Next update 13:45 Eastern or sooner as information becomes available.
Posted Jun 24, 2025 - 13:14 EDT
This incident affected: Platform (Americas (US West)).