The backlog has been completely processed and real time analytics is operating normally.
Posted Apr 22, 2026 - 12:43 EDT
Update
We are seeing significant improvement now and the backlogged events continue to be processed. Customers will continue to see latency until the backlog is completely processed. Next update 13:30 or sooner as information becomes available.
Posted Apr 22, 2026 - 12:34 EDT
Monitoring
Mitigation steps have been implemented and we are beginning to see improvement. Users will continue to experience delays until the backlogged events have been completely processed. Next update 12:30 Eastern or sooner as information becomes available.
Posted Apr 22, 2026 - 11:52 EDT
Update
The service teams continue to actively investigate root cause of the issue causing delays in real-time analytics. Customers will continue to experience delays in detail records, aggregate metrics, observation metrics and notifications until resolution and backlogged events are cleared. Next update 12:15 Eastern or sooner as information becomes available.
Posted Apr 22, 2026 - 11:32 EDT
Investigating
We are actively investigating an issue causing delays with all real time analytics data, including detail records, aggregate metrics, observation metrics and notifications. Next update 11:30 Eastern or sooner as information becomes available.
Posted Apr 22, 2026 - 10:56 EDT
This incident affected: Platform (Americas (US East)).