Genesys Cloud System Status

Normal Operations
Degraded Operations
Partial Outage
Outage
Under Maintenance

Genesys Cloud - Degraded Performance

Incident Report for Genesys Cloud

Resolved

This incident has been resolved.
Posted Apr 25, 2025 - 16:11 EDT

Monitoring

System operations have returned to normal levels. Continuous monitoring remains in place to ensure stability.
Posted Apr 25, 2025 - 16:07 EDT

Update

Additional mitigation steps have been implemented and testing is in progress. Customers who would like to test should refresh any open clients and attempt to use the application again.
Posted Apr 25, 2025 - 15:33 EDT

Update

We are continuing to investigate this issue.
Posted Apr 25, 2025 - 15:31 EDT

Update

Investigation remains ongoing across multiple teams. While testing continues, no new mitigation steps have been identified at this time. Next update 15:45 Eastern or sooner as information becomes available
Posted Apr 25, 2025 - 15:14 EDT

Update

Despite initial mitigation attempts showing minimal improvement, symptoms temporarily resolve upon client refresh but return with continued use. Multiple service teams are now collaborating to identify and address the root cause. Next update 15:15 PM or sooner as information becomes available.
Posted Apr 25, 2025 - 14:54 EDT

Update

A mitigation plan has been implemented and is currently undergoing testing to verify its effectiveness in resolving the performance issues. Next update 14:45 PM Eastern or sooner as information becomes available.
Posted Apr 25, 2025 - 14:31 EDT

Investigating

We are investigating an issue with degraded performance in both the web and desktop applications. Next update 14:30 or sooner as information becomes available.
Posted Apr 25, 2025 - 14:11 EDT
This incident affected: Platform (Americas (Sao Paulo), Americas (US East), Americas (US West), Americas (Canada), Asia Pacific (Mumbai), Asia Pacific (Sydney), Asia Pacific (Tokyo), Asia Pacific (Seoul), EMEA (Dublin), EMEA (Frankfurt), EMEA (London), FedRAMP, EMEA (Zurich), EMEA (UAE), Asia Pacific (Osaka)).