Genesys Cloud System Status

Normal Operations
Degraded Operations
Partial Outage
Outage
Under Maintenance

Elevated Error Rates EMEA (Frankfurt, Ireland, London)

Incident Report for Genesys Cloud

Resolved

This incident has been resolved.
Posted Dec 16, 2025 - 09:47 EST

Monitoring

Mitigation steps have been implemented. Customers will need to refresh the Genesys Cloud client for changes to take effect.
Posted Dec 16, 2025 - 09:44 EST

Identified

Root cause of the issue has been identified and the team is taking steps to mitigate. Next update 10:15 Eastern or sooner as information becomes available.
Posted Dec 16, 2025 - 09:38 EST

Investigating

Teams are investigating an issue where agents are unable to end callbacks due to call controls being grayed out. Next update 09:45 Eastern or sooner as information becomes available.
Posted Dec 16, 2025 - 09:18 EST
This incident affected: Platform (EMEA (Dublin), EMEA (Frankfurt), EMEA (London)).