Genesys Cloud System Status

Normal Operations
Degraded Operations
Partial Outage
Outage
Under Maintenance
PureCloud Voicemail Retrieval
Incident Report for Genesys Cloud
Resolved
The issue has been resolved. All voicemail messages are available.
Posted Mar 20, 2017 - 14:38 EDT
Identified
PureCloud users are experiencing issues retrieving voicemails. Voicemails are delivered and are available; however, once the browser is refreshed, users have reported being unable to access them. The development teams are engaged and applying a fix at this time. Updates to follow.
Posted Mar 20, 2017 - 13:53 EDT