Genesys Cloud System Status

Normal Operations
Degraded Operations
Partial Outage
Outage
Under Maintenance
PureCloud Admin Resources Unavailable
Incident Report for Genesys Cloud
Resolved
The issue has been resolved.
Posted Jan 20, 2017 - 11:25 EST
Identified
Admin users in PureCloud are experiencing issues with the admin link either not displaying, or the link producing a blank page. The development teams have identified the issue and are working to resolve at this time. Updates to follow.
Posted Jan 20, 2017 - 10:37 EST